Issue:
Time Machine backups stored on a My Cloud device are unable to be restored. This occurs due to bad credentials error when connecting as the Admin user.
Cause:
This occurs when Time Machine attempts to connect to the My Cloud with a user that has a blank password. This may also be caused by conecting a new Time Machine backup as a registered user to a public share, such as TimeMachine backup.
Solution:
Time Machine backups connected to a NAS drive's public share must be connected as Guest. In order to utilize the connect as Registered User, utilize the private shares's log in credentials. This must be done through the My Cloud Dashboard. Please see $EN_ANSWER_22007 for information on accessing the dashboard.