This answer explains what to do when a WD external (USB, FireWire, or eSata) drive is no longer given a drive letter (and as a result the data on the drive is inaccessible) by Windows or Mac PC.*END
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Important: Always connect the drive directly to the computer prior to testing. Do not use a USB or FireWire Hub. |
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| Windows OS | Click here for Instructions (instructions will appear below this table) |
| macOS | Click here for Instructions (instructions will appear below this table) |
Please select an Operating System (OS) from the table above to display instructions for the specific OS running at time of troubleshooting.
Windows OS
Issue:
A drive letter that used to appear under My Computer no longer does, and the data on the drive can no longer be accessed.
Cause:
There could be a few reasons why the drive is not showing up under Computer. The drive itself could have failed, the partition on the drive may be damaged, the data cable may no longer be good, or the drive may no longer be getting enough power to fully spin up.
Solution:
It's always best to start with the most simple possible causes when troubleshooting. Follow the steps below in order to eliminate the common simple issues:
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Note: | If after doing this the drive does not spin up at all, then either the drive or the power adapter has failed. The power adapter will need to be replaced to proceed with the troubleshooting. If after replacing the power adapter, the drive still doesn't spin up, then the drive needs to be replaced. Links for data recovery and warranty replacement below. |
- If the drive is not being recognized, disconnect the power adapter from the surge protector/UPS and plug directly into the wall. Sometimes, surge protectors diminish the power being supplied as more devices are added to them.
- If the drive is connected to a laptop docking station. The laptop docking station may not be supplying enough power to the drive. Try connecting the drive directly to the USB port on the laptop.
- Try connecting the drive to a different computer
- If the alternate computer can see and access the drive, the primary or other computers USB port may not provide enough power for the external drive
- Power from USB ports can vary. The use of a Power Booster cable may be needed to provide enough power to the USB drive. A Power Booster cable is a Y-shaped cable with an extra connector that allows for connecting a USB device to two USB ports on a computer
- For (My Book) connect the power adapter directly in to a wall socket if available
- If the drive is spinning but not recognized in My Computer, then change out the data cable with one that is a known good cable. Cables get old and the wires inside can break, or pull loose from the connectors.
- If that doesn't work, connect the external drive to another USB port. The USB port could be malfunctioning.
- If the drive still isn't being recognized, turn the PC off, disconnect the data cable, restart the computer, and once the operating system is fully up and running, reconnect the data cable. Give it a minute or two to recognize then access Disk Management to see if the drive shows up there. If it does show up in Disk Management then, check if it is seen with partition and format information or RAW. If ther is partition and format information, but no drive letter assigned, it may be possible to manually assign a drive letter. If there is no partition information or listed as RAW, there may be a corrupted or damaged partition and will require re-partition and reformat the drive for it to be recognized on the PC. See Links and note below.
- For help with reformatting the drive in Windows, see $EN_ANSWER_8200.
- For help with accessing Disk Management, see $EN_ANSWER_18075
- Perform a low-level format with Data Lifeguard Diagnostics for Windows from the Erase test option; particularly if the drive was initially used with a RAID controller to clean all previous partitioning information from the drive. Please see $EN_ANSWER_6226 for more information
- If the drive doesn't show up in Disk Management, then the last option is to connect the drive to another PC. If it works, then there's an issue with either the hardware or drivers on the primary PC. Troubleshooting will need to be performed on that computer and operating system. For help with the operating system, please contact Microsoft Support. For help with the computer hardware, please contact the computer manufacturer.
- If the external drive does not show up on another PC, then the drive has failed. Data recovery will be needed in order to recover the data stored on the drive. If the drive is under warranty, it can be replaced through us. Follow the links below.
- For Data Recovery please see our Data Recovery Partner Companies.
- For Warranty Replacement: $EN_ANSWER_10336.
| Critical: If there is data on the drive that is needed, do not reformat the drive. Data recovery will need to be performed on the drive, before reformatting the drive. With a damaged partition, there is data recovery software that may restore the data. Verious programs can be found by searching online. |
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Note: | If the computer does detect the drive, test the drive to make sure that there won't be any ongoing issues by using our Windows Data Lifeguard Diagnostics. For more information on how to use the software to test the drive, please see $EN_ANSWER_6226. |
If the software reports any errors for the drive, please see $EN_ANSWER_7519 for a list of error codes and what they mean.
| Critical: To avoid corrupting or losing the data on your external hard drive, always shut down the drive correctly before disconnecting the data cable from the drive or computer, or the power connection from the drive or the wall outlet. |
For more information on how to disconnect a WD external hard drive from your computer correctly, please see:
- $EN_ANSWER_12792
macOS
Issue:
I was using my external hard drive for some time and now a drive icon does not appear on my Mac Desktop or in Finder. As a result, the data on the drive can no longer be accessed.
Cause:
There could be a few reasons why the drive is not showing up in Finder, or the Mac Desktop. The drive itself could have failed, the partition on the drive may be damaged, the data cable may no longer be good, or the drive may no longer be getting enough power to fully spin up.
Solution:
It's always best to start with the most simple possible causes when troubleshooting. Follow the steps below in order to eliminate the common simple issues:
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Note: | If after doing this the drive does not spin up at all, then either the drive or the power adapter has failed. The power adapter will need to be replaced, in order to proceed with the troubleshooting. If after replacing the power adapter, the drive still doesn't spin up, then the drive will need to be replaced. Links for data recovery and warranty replacement can be found below. |
- If the drive is not being recognized, disconnect the power adapter from the surge protector/UPS and plug directly into the wall. Sometimes, surge protectors diminish the power being supplied as more devices are added to them.
- If the drive is spinning but not recognized, please change out the data cable with one that is known to be good. Cables get old and the wires inside can break, or pull loose from the connectors.
- If that doesn't work, connect the external drive to another USB or Firewire port. The USB/Firewire port could be malfunctioning.
- If the drive still isn't being recognized, turn off the Mac, disconnect the data cable, restart the computer, and once the operating system is fully up and running, reconnect the data cable. Give it a minute or two to recognize then please access Disk Utility to see if the drive shows up there. If it does show up in Disk Utility, then it may be a corrupted or damaged partition and will need to re-partition and reformat the drive for it to be recognized on the Mac. See the link and note below.
- For help with accessing Disk Utility, or reformatting your drive in Mac OSX, see $EN_ANSWER_8200.
- If the drive doesn't show up in Disk Utility, then the last option is to connect the drive to another Mac. If it works, then there's an issue with either the hardware or drivers on the primary Mac. Troubleshooting will need to be performed on that computer and operating system. Both of these are handled by Apple.
- If the external drive does not show up on another Mac, then the drive has failed. Data recovery will need to be performed to extract the needed data. If the drive is under warranty, it can be replaced through WD. Follow the links below.
- For Data Recovery please see our Data Recovery Partner Companies.
- For Warranty Replacement: $EN_ANSWER_10336.
| Critical: If there is data on the drive that is needed, do not reformat the drive. Data recovery will need to be performed on the drive, before proceeding with reformatting the drive. With a damaged partition, there is data recovery software that may restore the data. Various kinds of programs can be found on the internet. |
| Critical:
To avoid corrupting or losing the data on the external hard drive, don't forget to always shut down the drive correctly before disconnecting the data cable from the drive or computer, or the power connection from the drive or the wall outlet. If the computer does detect the drive, please test the drive by running First Aid. For assistance testing the drive please see $EN_ANSWER_14800. |
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Note: | This answer is highly recommended prior to returning a drive for a replacement. |
