This article explains Why the My Cloud Home Desktop App will not mount on macOS or Windows.
*END
Please click to view the Use of Third-Party Software or Websites disclaimer
Issue:
- My Cloud Home is not accessible via macOS, or Windows Desktop
- My Cloud Home will disappear from WD Discovery

Cause:
Acronis True Image Active Protection is preventing the My Cloud Home from mounting on the Desktop.
Solution:
Acronis True Image Active Protection
Make an exclusion for the My Cloud Home Desktop App.
macOS
- /Library/Application support/WDDesktop.App/contents/resources/kdd
Windows
- C:\Program Files\WD Desktop App\
Refer to Acronis True Image Knowledge Base Article 58297: Acronis Active Protection: How to Manage Exclusions